16:51
7 команда

 

МБОУ "Водоватовская СОШ" 9 класс

  1. Название команды-------USB

    Девиз-------Мы USB и  назад нет пути,только на взлет,за победой вперед!!!

НАША ЭМБЛЕМА

 

Список команды:

Галкин Сергей Иванович ( З-И-У-К)

Абрамова Лиза 7класс  ( З-И-У-К)

Малыгина Диана 7 класс ( З-И-У-К)

Непекин Никита 8 класс ( З-И-У-К)

Безроднов Дмитрий 10 класс ( З-И-У-К)

 

 

3 этап

задание 1


Задание 2  - Задача 11

паскаль:

const
    n = 100;
var
    a: array[1..n] of integer;
    i,m,k: integer;
begin
    write('Введите количество элементов массива: ');
    readln(m);
    write('Введите элементы массива ');
    for i:=1 to m do
        read(a[i]);
    for i:=2 to m-1 do
          if (a[i]<a[i-1]) and (a[i]<a[i+1]) then k:=k+1;
    writeln('Количество  элементов, которые меньше соседей =  ', k);
end.

кумир

алг
нач
цел i,m,k
k:=0
целтаб a[1:100]
вывод " Введите количество элементов массива"
ввод m
вывод " Введите элементы массива"
нц для i от 1 до m
ввод a[i]
кц
нц для i от 2 до m-1
если a[i]<a[i-1] и a[i]<a[i+1] то k:=k+1 всё
кц
 вывод "Кол-во элементов, которые меньше соседей ", k
кон

Задание 3

Контрольная работа 8
задание 1
второй -n+1;  третий -n+2; предпоследний 2n; третий с конца 2n-1; С индексом 0   n+1

2 а) x[0]=2 x[1]=8 x[2]=10 x[3]=3 x[4]=2 x[5]=-6
2 б) 9
2 в) не выведет (ошибка)
2 г) x[0]=3 x[1]=2 x[2]=-6 x[3]=2 x[4]=8 x[5]=10

3 а) x[0]=1 x[1]=3 x[2]=6 x[3]=9
3 б) x[0]=9 x[1]=6 x[2]=3 x[3]=1
3 в) x[0]=6 x[1]=3 x[2]=1 x[3]=9
3 г) x[0]=3 x[1]=0 x[2]=6 x[3]=-2

Контрольная работа 9
1 а) 2 2
1 б) 7 5 2 3
1 в) 3 2 5 7 2
1 г) 0 1 2 3 4
1 д) 2 2 3 5 7

2 ничего не выводит.

 

 

 

 

 

 

 

назад к проекту

Категория: К вершинам программирования | Просмотров: 275 | Добавил: tatiana | Рейтинг: 0.0/0
avatar